npm

Installing bcrypt on Windows

bcrypt requires both python > 2.6 < 3.0 and the Microsoft C++ build tools.

If Python 3+ is in your path you will need to specifcy the path to python 2

npm config set python C:\Python27\python.exe

For the Microsoft C++ build tools you will have to install Visual Studio Express. If you have Visual Studio Express 2010 installed you should be able to install bcrypt with npm fine, however if you have a later version or download the current (2013) than you need to specify the version in the npm install command.